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Chapter 1: Using Projects in ADS
Advanced Design System uses projects to automatically organize and store the data
generated when you create, simulate, and analyze designs to accomplish your design
goals.

A project includes circuit, layout, simulation, analysis, and output information on the
designs that you create, along with any links you add to other designs and projects.

Use the Main window to create and open projects. This window is displayed when you
launch Advanced Design System.

Simulation Data
Momentum Designs & Data
Schematic & Layout Designs
DSP Synthesis Data
Design Rule Checker Data
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Using Projects in ADS
Creating Projects
Use the Main window to create a project that you can then use to organize your
designs. A project includes circuit, layout, simulation, analysis, and output
information on the designs that you create, along with any links you add to other
designs and projects.

To create a project...

1. Choose
File > New
Project

2. Enter
Project Name
& Location
1-2



Opening Projects
Only one project can be open at a time. When you begin to open a project, you are
prompted to save any changes you have made in the currently open project before it is
closed automatically.

To open a project...

1. Choose File > Open Project and use the dialog box to locate and open the project.

2. Use the File Browser pane of the Main window to locate the project and
double-click to open it.

Double-click to
open project
1-3



Using Projects in ADS
Sharing Projects
Use the Main Window to reuse and share projects without having to manually
include all the individual parts that make up a project.

• Add links to create a hierarchical project

Choose File > Include/Remove Projects and use the dialog box to locate and link
to the project.

• Create a copy to replicate a project

Choose File > Copy Project and use the dialog box to locate and copy the project.

• Archive/Unarchive to transfer a compact project archive

Choose File > Archive Project and use the dialog box to locate and archive the
project.
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Chapter 2: Using Designs in ADS
Advanced Design System uses designs to store the schematic and layout information
you generate to accomplish your design goals.

A design can consist of a single schematic or layout, or it can be made up of a number
of schematics and layouts embedded as subnetworks within a single design. All
designs in a project can be displayed and opened directly from the Main window or
from within a Design window.

In a Design window you can:

• Create and modify circuits and layouts

• Add variables and equations

• Place and configure components, shapes, and simulation controllers

• Specify layer and display preferences

• Include annotations using text and illustrations

• Generate layouts from schematics (and schematics from layouts)

The basic process of creating a design or layout is as illustrated:

Place
Component

Rotate
Component

Define
Parameters

Add Ports

Connect
Component

Generate Reports
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Using Designs in ADS
Creating Designs
You can create a new design (layout) using one of two ways:

• Choose Window > New Schematic in the Main window or File > New Design in the
Schematic (Layout) window and use the dialog box to name the file you are
creating.

• Choose Insert > Template in the Schematic window and select a template for the
new file.

When you use a template, most of the initial setup and configuration for the
schematic, the simulation, and the data analysis is done for you automatically.

To create a design...

Choose Window >
New Schematic
2-2 Creating Designs



Listing Designs
Even after you close all Schematic and Layout windows, designs that you opened
remain in memory until you explicitly clear them or exit the program.

To list designs...

• Choose the design from the Window menu in the Schematic (Layout) window.

• Double-click the Networks directory in the Main window to display all designs,
and then double-click a design to list its schematic, layout, and hierarchical
information.
Listing Designs 2-3



Using Designs in ADS
To view the component hierarchy within a design, choose Tools > Hierarchy from the
schematic window to display the Hierarchy dialog box for the design. To view the
design hierarchies within a project, choose View > Design Hierarchies from the Main
window to display the Design Hierarchies dialog box.
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Opening Designs
You can use either the Main window or the Schematic (Layout) window to open a
design (layout).

• Choose File > Open in the Schematic (Layout) window and use the dialog box to
locate and open the design.

• Use the File Browser pane of the Main window to locate the design (layout) and
double-click to open it.

To open a design...

Double-click to
display design
Opening Designs 2-5



Using Designs in ADS
Adding Components
You can place, connect, and configure the following items in the drawing area of your
design window to create your design.

• Components

• Data items

• Measurement sources

• Simulation controllers

You can also add entire circuits as subnetworks to create hierarchical designs. Keep
in mind that when you begin a design using a template, most of the simulation and
analysis setup and configuration is done for you automatically.

To add a component...

1. Select
Component
2. Define
Orientation
3. Place
Component
4. Edit
Parameters
2-6 Adding Components



Drawing Shapes
To create a layout, you can draw and modify shapes in the drawing area of your
design window to create your layout. You can also add Traces to represent electrical
connectivity.

To place a shape:

• Choose the shape from the Draw menu or click the appropriate button on the
toolbar

Draw the shape at the desired location in the drawing area.
Drawing Shapes 2-7



Using Designs in ADS
To draw a shape...

Select the shape and... To draw...

1. Click to start the first segment

2. Click to end a segment and start a new segment

3. Double-click to complete the shape

Polygon

1. Click to start the first segment

2. Click to end a segment and start a new segment

3. Double click to end the last segment

Polyline

1. Click to mark the first corner

2. Drag to define the rectangle

3. Click to mark the second corner

Rectangle

1. Click to mark the center

2. Click to mark a point on the perimeter

Circle

1. Click to mark the location

2. Start typing

Text

1. Select a corner type

2. Enter width and corner cutoff ratio

3. Click to mark the start

4. Click to mark the end

Path

1. Click to mark the start

2. Click to mark the center

3. Click to mark the end

Arc
2-8 Drawing Shapes



Synchronizing Designs
Use Design Synchronization (Schematic window > Layout > Generate/Update Layout
OR Layout window > Schematic > Generate/Update Schematic) to generate and
synchronize your schematic and layout artworks and symbols. The window where
you invoke the synchronization operation acts as the source from which the
destination representation is generated or updated.
Synchronizing Designs 2-9



Using Designs in ADS
Synchronization Modes

The synchronization can be complete or incremental and can be done to and from a
schematic and a layout.

Generate Update Place Component

Place all activated
components, including those
with no artwork, connected
to the starting component.

Update a previously
generated design by
placing components
that have been
modified.

Place items that have no
counterparts in the other
representation.

Components with fixed
location status are not
moved.

Components with fixed
location status are not
moved.

Use the “Current Rep only”
component placement mode

Components that are not
placed in the other
representation are
highlighted

“Wire guides” show connectivity
in the other representation

Any component can serve
as the starting point for
which the location,
orientation can be specified

Use the “Options > Variables”
command to override the default
resolution path for variable- and
substrate- references
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Documenting Designs
Advanced Design System includes a documentation tool for creating HTML
documents using the designs and results within a project. This “Electronic Notebook”
generation tool can be used to:

• Capture schematic, layout, and data display images in a project, and import
images from other sources.

• Generate html documentation that can be distributed and viewed outside of
ADS.

To document designs...

1. Choose Tools >
Electronic Notebook
2. Document Design
Documenting Designs 2-11
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Chapter 3: Simulating Designs in ADS
Advanced Design System provides controllers that you can add and configure to
simulate, optimize, and test your designs.

A DSP design simulation requires a Data Flow Controller while an Analog/RF design
simulation requires one or more of various controllers. You can either add and
configure the appropriate controllers or you can insert a template (choose Insert >
Template from a Schematic window) that contains the appropriate controllers.

To simulate a design...

1. Click and
place
controller

2. Click to
edit
parameters

3. Click to
simulate
design
3-1



Simulating Designs in ADS
The status of the simulation is displayed in a message window.

Click to see information on simulation and convergence issues and tips for Analog/RF
Simulation.

Simulation Wizard
Advanced Design System also provides a step-by step interface for circuit simulation.
This “Smart Simulation Wizard” can be used to:

• Create circuit schematics

• Set up and run simulations

• Display simulation results
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To “smart” simulate a design...

Analog/RF Simulation and Convergence
Analog/RF simulation computes the response of a circuit to a particular stimulus by
formulating a system of circuit equations and then solving them numerically. Each
simulation technology accomplishes this analysis as follows.

DC Analysis

• Solves a system of nonlinear ordinary differential equations (ODEs)

• Solves for an equilibrium point

1. Choose Simulate >
Smart Simulation
Wizard
2. Specify Circuit
Configurations
3. Specify Simulation
Options
4. Display Results
Analog/RF Simulation and Convergence 3-3



Simulating Designs in ADS
• All time-derivatives are constant (zero)

• System of nonlinear algebraic equations

Transient Analysis

• Solves a system of nonlinear ordinary differential equations (ODEs)

• Time-derivatives replaced with a finite-difference approximation (integration
method)

• Sequence of systems of nonlinear algebraic equations (one system at each
timepoint)

Harmonic Balance (HB)

• Solves a system of nonlinear ordinary differential equations (ODEs)

• Steady-state method

• Solution approximated by truncated Fourier series

• System of nonlinear ODEs becomes a system of nonlinear algebraic equations
in the frequency domain

Common Circuit Simulation Methods

Backward Euler

• First order method that assumes the solution waveform is linear over one time
step

• One-step method (needs one previous time point solution only)

• Adapts faster to abrupt signal changes

• Stable on all stable differential equations and some unstable ones.

• Exhibits heavy numerical damping, increases loss

• Require smaller time step to maintain accuracy
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Trapezoidal Rule

• Second-order method, assumes the solution waveform is quadratic over one
time step

• One-step method

• May exhibit point-to-point ringing on circuits that have very small time
constant comparing to time step (stiff circuit)

• Stable only on stable differential equations

• Exhibits no artificial numerical damping

Backward Difference Formulas (Gear's methods)

• Multiple order polynomial over one time step

• Only the first six orders are available in ADS

• First order method is identical to backward Euler

• Higher-order polynomials allow a larger time step without sacrificing accuracy,
are efficient for smooth waveforms

• Higher order methods (order > 2) may exhibit stability problems on lightly
damped circuits

• Second-order backward difference formula (Gear 2)

• Two-step method

• Stable on all stable differential equations and some unstable ones.

• Exhibit some numerical damping

Truncation Error

The error made by replacing the time derivatives with a discrete-time approximation.
This error is difficult to estimate and depends on the type of circuits and the time
steps.

Local Truncation Error (LTE)

The truncation error made on a single step
Common Circuit Simulation Methods 3-5



Simulating Designs in ADS
Global Truncation Error (GTE)

• Maximum accumulated truncation error

• The circuit with long time constant is sensitive to these errors

• Logic and bias circuits are not sensitive to these errors

Convergence Criteria

Newton's iteration is converged if the approximate solution first satisfies the Residue
criteria at the end of each Newton iteration and the Update criteria once the residue
criteria are satisfied.

Residue criterion

KCL satisfied to a given tolerance. This is enforced at each node and is important
when impedance at a node is small.

Update criteria

Difference between the last two iterations must be small. This is important when
impedance at a node is large.

Using Continuation Methods
Use continuation methods to provide a sequence of initial guesses that are
sufficiently close to the solution to assure Newton's method convergence.

• Choose a natural or contrived continuation parameter which controls a
modification of the circuit

• Step the continuation parameter from 0 to 1 (the original circuit configuration),
using the solution from the previous step as the starting point

As long as the solution changes continuously as a function of the continuation
parameter and the steps are small enough, Newton's method will converge. Keep in
mind though that the first two methods, Source and gmin stepping, will fail if the
continuation path contains a limit point.
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Source Stepping

Uses a fraction of the source voltages and currents applied to the circuit as the
continuation parameter.

• Turn off all sources when the continuation parameter equals 0

• Raise source levels to their final levels slowly, generating a sequence of circuit
configurations

• Use the solution from the previous configuration as an initial guess for the
current configuration

Gmin Stepping

Uses the continuation parameter to control the value of the gmin resistors

• Start with a large gmin for an easy to compute solution because nonlinear
device behavior is muted by the presence of the small resistors

• End with very small gmins for resistors that are so large that they no longer
affect the circuit

• Remove the gmins to compute the final solution

Arc-length Continuation

Works best for complicated continuation paths and limit points using a continuation
parameter that is a function of the arc-length parameter

• Travel same distance at each step, as specified by the arc-length

• Increase or decrease the continuation parameter along the path in each step

Preventing Convergence Problems

Convergence problems usually arise as a result of errors in circuit connectivity or
unreasonable (out of range) model or component values. Some of the steps you can
take are as follows.

• Turn on the topology checker

• Turn on warnings

• Act upon the messages in the ADS Status Server window
Using Continuation Methods 3-7



Simulating Designs in ADS
• Eliminate small floating resistors (or increase I_AbsTol) because any error in
computed voltages for nodes with small resistors results in large error currents

• Avoid very large and very small resistances connected to a node because large
resistances are lost during Jacobian construction due to numerical round-offs

Simulation Controllers
Add one or more simulation controllers to the design based upon the type of design to
be simulated and the kinds of analyses desired.

Description Typical Use

Data Flow Simulation Controller
Controls the flow of mixed numeric and timed signals
for digital signal processing simulations using the
Agilent Ptolemy simulator.

All signal
processing
designs

DC Simulation Controller
Fundamental to all RF/Analog simulations. It performs
a topology check and an analysis of the DC operating
point.

All RF/Analog
designs

AC Simulation Controller
Obtains small-signal transfer parameters like voltage
gain, current gain, and linear noise voltage and
currents.

Filter
Amplifier

S-Parameter Simulation Controller
Provides linear S-parameter, linear noise parameters,
transimpedance, and transadmittance. Can be used to
achieve many goals of the AC simulator.

Filter
Oscillator
Amplifier

Harmonic Balance Simulation Controller
Uses nonlinear harmonic-balance techniques to find
the steady-state solution in the frequency domain.

Mixer
Oscillator
Power amplifier
Transceiver

Circuit Envelope Simulation Controller
Uses a combination of frequency- and time-domain
analysis techniques to yield a fast and complete
analysis of complex signals such as digitally modulated
RF signals.

Mixer
Oscillator
Power amplifier
Transceiver
Phase-locked
loop
3-8 Simulation Controllers



Optimization & Statistical Design Controllers
Optimization and statistical design controllers are used in conjunction with
RF/Analog and signal processing simulation controllers to:

• Characterize and improve an unknown process such as the response of a design

• Identify variables that contribute significantly to variations in performance

• Vary parameter values to identify combinations that deliver the desired yields

Some of their typical design applications include:

• Filter response optimization

• Pulse-rise time tuning

• Carrier lock time and residual loop error optimization

• Fixed-point bit-width optimization

• Maximize manufacturing yield

Advanced Design System includes the following optimization and statistical design
controllers.

Nominal Optimization

Compares computed and desired responses and modifies parameter values to yield a
computed response that meets the specified optimization goals.

LSSP Simulation Controller
Performs large-signal S-parameter analyses to
represent nonlinear behavior. The accompanying P2D
simulator can be used to speed up subsequent
analyses.

Power amplifier

XDB Simulation Controller
Seeks a user-defined gain-compression point at which
an actual power curve deviates from an idealized linear
power curve.

Power amplifier
Mixer

Transient/Conv. Simulation Controller
Solves a nonlinear circuit entirely in the time domain
using simplified models to account for the
frequency-dependent behavior of distributed elements.

Mixer
Power amplifier
Switching circuits
Optimization & Statistical Design Controllers 3-9



Simulating Designs in ADS
• A Goal controller is used in conjunction to specify the optimization goals.

Yield Analysis

Uses the Monte Carlo method to randomly vary statistical distributions of parameter
values to determine possible combinations that deliver the desired yields.

• A Yield Specification controller is used in conjunction to specify the desired
yields.

• A Statistical Correlation controller is used to specify statistical correlation
between design variables.

Yield Optimization

Analyzes multiple yield analyses and adjusts the yield variable nominal values to
maximize the yield estimate.

Design of Experiments

Sequentially and iteratively improves the statistical performance of a design by
identifying variables that contribute significantly to performance variation and
honing in on the target statistical response.

• A DOE Goal controller is used in conjunction to specify the desired goals.
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Chapter 4: Analyzing Results in ADS
Advanced Design System uses datasets to store the simulation information you
generate when analyzing designs. You can display this information for analysis using
the Data Display window. A Data Display window can also be used to display data
imported from other sources such as a network analyzer.

In a Data Display window you can:

• Display data in a variety of plots and formats

• Use markers to read specific data points on traces

• Use equations to perform operations on data

• Annotate results using text and illustrations

Once a simulation is complete the data is displayed automatically if you did one of
the following (a blank Data Display window is opened if you did none of them):

• Specified a dataset and display before simulation

• Used a schematic template for an Analog/RF simulation

• Specified Rectangular in the Plot parameter in a sink for a Signal Processing
simulation
4-1



Analyzing Results in ADS
Creating Data Displays
The basic process of creating a data display is as illustrated:

1. Choose the dataset that contains the data you want to display

2. Choose a plot type for the display

3. Select the data variable to be displayed

4. Choose a trace type for the display

To enhance the display you can also add:

• Markers to identify specific data points

• Annotations using text and illustrations

If you used a template to create the design you have simulated, the initial setup and
configuration to create displays for data analysis is done for you automatically.

Choose
Dataset

Choose
Plot Type

Choose
Trace Type

Add Ports

Select
Data Variable

Generate Reports
4-2 Creating Data Displays



To create a data display...

1. Click to open
Data Display

2. Click and place
a plot

3. Select dataset,
plot, and trace
options
Creating Data Displays 4-3



Analyzing Results in ADS
Viewing Results
To view simulation results from the Main, Schematic, or Layout window choose
Window > Open Data Display and use the dialog box to locate and open the results.

Note: To display a list of data display files in the File Browser pane of the Main
window you will need to be sure the Show All Files option (View > Show All Files) is
selected.

To display simulation results...

1. Open Data
Display Window

2. Select Results
File

3. Display
Simulation Results
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Display Options

The following plot, trace, and data options can be used to display data for analysis:

Using Functions
You can use Measurement Equations to perform operations on data generated during
a simulation. These equations are creating using functions that are based on AEL,
the Application Extension Language.

Note: Data from a marker can also be used as part of an equation. To insert a
marker choose Marker > New and click the trace where you want to insert it.

Plot Type Trace Type Data Source

Rectangular plot
Stacked plot
Smith chart
Polar plot

Auto, Bus,
Linear, Scatter,
Spectral,
Histogram,
Digital, Sampled

Simulation dataset
Files
Network analyzer
Spectrum analyzer
Oscilloscope
Microwave Transition analyzer

List
Using Functions 4-5



Analyzing Results in ADS
To create and insert a function...

1. Click and place
Equation

2. Enter Equation
4-6 Using Functions



Chapter 5: ADS Inputs and Outputs
To import or export a design (schematic or layout):

• Choose File > Import (or Export) from a Schematic or Layout window

• Choose a file type

• Enter a file name

To import or export data:

• Choose Window > New File/Instrument Server from a Schematic window

• Click Read (or Write)

• Specify a file type and path

Translating Series IV Projects and Designs
When you translate a Series IV project or design into Advanced Design System, the
process creates a copy and then translates the copy into an Advanced Design System
format. Each Series IV component is replaced by an equivalent ADS component and
layout geometry is preserved.

Note: Translate an entire Series IV project when you want more than one design or
when the design you want is hierarchical.

The basic process of translating a Series IV project or design into Advanced Design
System is:

Import
the Design

Verify Component
translation

Simulate
the Design

Compare
Simulation Results

Prepare Design for
Simulation
Translating Series IV Projects and Designs 5-1



ADS Inputs and Outputs
Translating MDS Projects and Designs
When you translate an MDS project or design into Advanced Design System, the
process creates a copy and then translates the copy into an Advanced Design System
format. Each MDS component is replaced by an equivalent ADS component and
layout geometry is preserved.

Note: Translate an entire MDS project when you want more than one design or
when the design you want is hierarchical.

The basic process of translating an MDS project or design into Advanced Design
System is:

Import
the Design

Verify Component
translation

Simulate
the Design

Compare
Simulation Results

Prepare Design for
Simulation
5-2 Translating MDS Projects and Designs



Formats for Design Exchange

Drawing Exchange Format (DXF)

This format was developed by Autodesk for its AutoCAD product to transfer
geometric data between systems. Like the mask file format, it provides a simple
geometric representation of data. DXF files can be transferred between PC-based or
UNIX-based systems.

Engineering Graphics System (EGS)

This format is a general graphics format used for capturing manually entered
designs. EGS has been applied to ICs, Micro-circuits, Hybrids, and PC Board design
applications. Using this format, you can easily exchange data with other programs
using EGS formats. In addition, EGS facilitates better artwork translation with
Advanced Design System.

• The Generate format is a flattened list of EGS primitives specified in the
user-defined unit space.

Format Import Export

DXF (.dxf) Layout

EGS Archive Format (_a) Layout Layout

EGS Generate Format (_g) Layout
Schematic

Layout

GDSII Stream Format (.gds) Layout Layout

Gerber (.gbr) Layout

Gerber Viewer (.msk, .gbr) Layout

HPGL/2 (.hpg) Layout
Schematic

Layout

HP IFF (.iff) Layout
Schematic

Layout
Schematic

IGES (.igs) Layout Layout

Mask File (.msk) Layout
Schematic

Layout

MGC/PCB (.iff) Layout

Spice (.cir, .cki, .iff, .net) Schematic
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ADS Inputs and Outputs
• The Archive Format is a hierarchically organized list of EGS primitives
specified in the user-defined unit space. Information such as drawing shapes,
layout units, database precision, and grid spacing is included.

GDSII Stream Format (Calma)

This format is an industry standard for translating final mask data to foundries.
Advanced Design System reads GDSII versions 4.0 through 6.0 and writes GDSII
version 6.0. Unlike other data formats, GDSII stream format is binary. You cannot
easily view or edit a stream format file using a text editor. This format is easily
translated between different CAD systems because it represents a highly restrictive
data type.

Gerber

This format refers to various data input formats that Gerber Scientific uses to drive
its photoplotters. The Gerber format is used by photoplotters produced by other
manufacturers also. The program supports various types of Gerber output via mask
files to either the Gerber or DXF translator.

Gerber Viewer

This format appears as an export file option. It is not a file format, but you can use it
to view Gerber or mask files to help verify the correctness of your data if the files
meet the following criteria:

• Use either absolute or incremental data coordinates

• Support apertures from D10-D999

• Have data formats from 0.1 to 4.5

HPGL/2

This format is a subset of the HPGL/2 printer/plotter language. When creating a
graph or chart in another tool, you can write the graphics data to an HPGL/2 output
file, then import the file into Advanced Design System. In Advanced Design System,
the HPGL data is transformed into forms and shapes that can be edited and
manipulated like any other drawing. Additional text, annotation, scaling or editing
may be added.
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Intermediate File Format (IFF)

This format is an ASCII file with a simple, line-oriented command structure and a
fairly rich set of constructs. This format is machine- and application-independent,
thus simplifying design data transfer. IFF files are used as the exchange mechanism
when transferring designs between Advanced Design System and third-party EDA
tools such as Mentor Graphics Design Architect and Cadence Analog Artist.

Initial Graphics Exchange Specification (IGES)

This format is an approved ANSI standard that is used extensively throughout the
computer-aided design and manufacturing world. It can represent both mechanical
and electrical design data in two and three dimensions. The IGES standard for the
transfer of electrical design data is known as CALS specification. Advanced Design
System supports version 4.0 and 5.0 IGES formats. It reads and writes IGES CALS
Level 1 (technical illustration) and Level 3 (electrical/electronic applications) files.

Mask

This format is a simple flat (non-hierarchical) geometric description. The format
facilitates the transfer of simple geometric data for final mask processing. Only
geometric forms are described in a mask file; simulation data, element parameters,
substrate definitions, and hierarchy are not included.

MGC/PCB

These files are IFF files that are used exclusively for Mentor Graphics design
transfers. MGC/PCB files write to a specific location each and every time. When you
select this format, the filename and location of the IFF transport is determined
automatically.

Spice

Simulation Program with Integrated Circuit Emphasis (Spice) has become a
simulation tool used by engineers throughout the world for simulating circuits of all
types. After its development at the University of California Berkeley, Spice has been
commercialized and modified by a large number of vendors and also adopted and
modified by electronics companies for their own in-house use.
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Formats for Data Transfer
Format Description Usage

Touchstone (SnP) Format

SnP Small signal S, H, Y, Z, or
G-parameters. May also include
optional noise data (2 port data
only). Where n is the number of
ports from 1 to 99.

n-Port S-parameter file (SnP)
components in the Data
Items Library.

When writing data from a dataset to a file, the variable names are limited to S,H,Y,Z or G, for
example, S[1,1], S[1,2], G[1,1], G[1,2]. The variable name is used to determine the type of
data.
The first set of data in the dataset that matches the data type (name) will be output. It is not
possible to arbitrarily select which data will be will be output.

CITIfile Format

CITI A general data format
supported by network
analyzers. Capable of storing
multiple packages of
multi-dimensional data.

S#P #-Port S-parameter file
components in the Data
Items Library.

There are some specific problems with the current version in writing and/or reading this data
format. Refer to the release notes or on the Agilent EEsof support Web site for more
information and workarounds.

Agilent IC-CAP Formats

 DUT, MDL, SET Device under test (DUT), model
(MDL), and setup (SET) files
from the Agilent IC-CAP
software. These files can
contain Measured, Simulated,
and/or Transformed data.

Once the data is read into a
dataset, it can be used with
any component (for example,
a VtDataset source) that can
read data from a dataset.

You can read in IC-CAP data only.
Only simple, scaled expressions with numbers or variables and one operator (either +, -, *, or /)
are supported for start, stop, step, and number of points parameters, for example, start= 1 GHZ
or stop=icmax/10.

MDIF Formats

 DSCR Discrete (indexed) tabular and
possibly statistical density data.

DAC

GCOMP  Gain compression data Amplifier and Mixer items in
the System - Amps & Mixers
library.
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GEN_MDIF Generalized multi-dimensional
tables unifying other MDIF
formats.

DAC

IMT Intermodulation product table of
mixer intermodulation products
between the LO and signal that
relates the mixer IM output level
to signal input level.

MixerIMT in the System -
Amps & Mixers library.

MODEL_MDIF Nonlinear model parameters EEFET1, BJTAP, etc.

P2D Large-signal, power-dependent,
2-port S, H, Y, Z, or G
-parameters.

AmplifierP2D item in the
System - Amps & Mixers
library.

PDF User defined, piece-wise linear
probability density function
data.

With expressions in the
Statistics tab.

The PDF format is not yet fully supported.

S2D 2-port S, H, Y, Z, or
G-parameters with gain
compression and optional noise
and intermodulation data.

Amplifier S2D, Amplifier, and
Mixer items in the System -
Amps & Mixers library.

S2PMDIF Multi-dimensional 2-port, S, Y,
Z, H, G signal and optional
2-port noise parameter (Fmin,
Gopt, Rn) data.

With S2PMDIF and DAC

SDF Time-domain voltage data file in
HP89440 file format.

TimeFile item in Timed
Sources and OutFile item in
Sinks library.

SPW Time-domain voltage data file in
Cadence Alta Group SPW
format

TimeFile item in Timed
Sources and OutFile item in
Sinks library.

TIM Time-domain data TimeFile item in Timed
Sources and OutFile item in
Sinks library.

When writing data from a dataset to a file, the variable names are limited to S,H,Y,Z or G, for
example, S[1,1], S[1,2], G[1,1], G[1,2]. The variable name is used to determine the type of
data.
The first set of data in the dataset that matches the data type (name) will be output. It is not
possible to arbitrarily select which data will be will be output.
There are some specific problems with the current version in writing and/or reading this data
format. Refer to the release notes or on the Agilent EEsof support Web site for more
information and workarounds.
Obsolete Formats: COD, FIR, LAS, SPE, LIST2, and T2D.
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Chapter 6: ADS Simulation Controllers

Data Flow Simulation Controller
Use the Data Flow controller to control the flow of mixed numeric and timed signals
for all digital signal processing simulations within Advanced Design System. This
controller works with the sink components to provide you flexibility to control the
duration of the simulation globally or locally.

While you need only one controller per schematic, you can place multiple controllers
on the schematic either at the top-level design or inside the hierarchical
subnetworks. All controllers in a design are simulated in sequence.
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DC Simulation Controller
The DC controller provides for both single-point and swept simulations. Swept
variables can be related to voltage or current source values, or to other component
parameter values. By performing a DC swept bias or a swept variable simulation, you
can check the operating point of the circuit against a swept parameter such as
temperature or bias supply voltage.

Use the DC controller to:

• Verify the proper DC operating characteristics of the design under test.

• Determine the power consumption of your circuit.

• Verify model parameters by comparing the DC transfer characteristics (I-V
curves) of the model with actual measurements.

• Display voltages and currents after a simulation.

A DC simulation is the first analysis for most other analyses. It uses a system of
nonlinear ordinary differential equations (ODEs) to solve for an equilibrium point in
the linear/nonlinear algebraic equations that describe a circuit once:

• Independent sources are constant valued

• Capacitors and similar items are replaced with open circuits

• Inductors and similar items are replaced with short circuits

• Time-derivatives are constant (zero)

Linear elements are replaced by their conductance at zero frequency
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AC Simulation Controller
A linear AC analysis is a small-signal analysis. For this analysis the DC operating
point is found first and then the nonlinear devices are linearized around that
operating point. Small-signal AC simulation is also performed before a
harmonic-balance (spectral) simulation to generate an initial guess at the final
solution.

Use the AC controller to:

• Perform a swept-frequency or swept-variable small-signal linear A simulation.

• Obtain small-signal transfer parameters, such as voltage gain, current gain,
transimpedance, transadmittance, and linear noise.

An AC simulation also offers a linear noise simulation option that can include the
following noise contributions in its simulation:

• Temperature-dependent thermal noise from lossy passive elements, including
those specified by data files.

• Temperature and bias-dependent noise from nonlinear devices.

• Noise from linear active devices specified by two-port data files that include
noise parameters.

• Noise from noise source elements.

The noise simulation computes the noise generated by each element, and then
determines how that noise affects the noise properties of the network.
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S-Parameter Simulation Controller
The S-Parameter controller is used to define the signal-wave response of an n-port
electrical element at a given frequency. It is a type of small-signal AC simulation that
is most commonly used to characterize a passive RF component and establish the
small-signal characteristics of a device at a specific bias and temperature.

Use the S-Parameter controller to:

• Obtain the scattering parameters (S-parameters) of a component or circuit, and
convert the parameters to Y- or Z-parameters.

• Plot, for example, the variations in swept-frequency S-parameters with respect
to another changing variable.

• Simulate group delay.

• Simulate linear noise.

• Simulate the effects of frequency conversion on small-signal

• S-parameters in a circuit employing a mixer.

S-parameter simulation normally considers only the source frequency in a noise
analysis. Use the Enable AC Frequency Conversion option if you also want to
consider the frequency from a mixer’s upper or lower sideband.
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Harmonic Balance Simulation Controller
The Harmonic Balance controller is best suited for simulating analog RF and
microwave circuits. It is a frequency-domain analysis technique for simulating
distortion in nonlinear circuits and systems. Within the context of high-frequency
circuit and system simulation, harmonic balance offers the following benefits over
conventional time-domain transient analysis:

• It captures the steady-state spectral response directly.

• Many linear models are best represented in the frequency domain at high
frequencies.

• The frequency integration required for transient analysis is prohibitive in many
practical cases.

Use the Harmonic Balance controller to:

• Determine the spectral content of voltages or currents.

• Compute quantities such as third-order intercept points, total harmonic
distortion, and intermodulation distortion components.

• Perform power amplifier load-pull contour analyses.

• Perform nonlinear noise analysis.

Harmonic Balance enables the multitone simulation of circuits that exhibit
intermodulation frequency conversion, including frequency conversion between
harmonics. It is an iterative method that assumes that for a given sinusoidal
excitation there exists a steady-state solution that can be approximated to a
satisfactory accuracy.
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Simulation Overview

Harmonic balance is a frequency-domain analysis technique for simulating distortion
in nonlinear circuits and systems. It obtains the frequency-domain voltages and
currents to calculate the spectral content of voltages or currents in the circuit. The
harmonic balance method is iterative. It is based on the assumption that for a given
sinusoidal excitation there exists a steady-state solution that can be approximated to
satisfactory accuracy by means of a finite Fourier series.

The Harmonic Balance solution is approximated by truncated Fourier series and this
method is inherently incapable of representing transient behavior. The
time-derivative can be computed exactly with boundary conditions, v(0)=v(t),
automatically satisfied for all iterates.

The truncated Fourier approximation + N circuit equations results in a residual
function that is minimized.

N x M nonlinear algebraic equations are solved for the Fourier coefficients using
Newton’s method and the inner linear problem is solved by:

• Direct method (Gaussian elimination) for small problems

• Krylov-subspace method (e.g. GMRES) for larger problems

Nonlinear devices (transistors, diodes, etc.) in Harmonic Balance are evaluated
(sampled) in the time-domain and converted to frequency-domain via the FFT.

Advantages

• Harmonic balance captures the steady-state spectral response directly while
conventional transient methods need to integrate over many periods of the
lowest-frequency sinusoid to reach steady state.

• Harmonic balance is faster at solving typical high-frequency problems that
transient analysis can’t solve accurately or can only do so at prohibitive costs.

• Harmonic balance is more accurate at solving high frequencies where many
linear models are best represented in the frequency domain.

Convergence

Nonconvergence is a numerical problem encountered by the harmonic balance
simulator when it cannot reach a solution, within a given tolerance, after a given
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number of numerical iterations. There is no one specific solution for solving
convergence problems. However, consider the following guidelines:

• Increase the Order (or other harmonic controls); this is the most basic technique
for solving convergence problems, if the time penalty for doing so is acceptable.

• Use the Status server window as the main tool in solving convergence problems
(set StatusLevel=4). For each Newton iteration the L-1 norm of the residuals
throughout the circuit is printed: a “*” indicates a full Newton step (vs. a
Samanskii step).

• Convergence criteria are controlled by Voltage relative tolerance, and Current
relative tolerance (in the Options component, under the Convergence tab). In
general, convergence speed is improved by increasing these values, but at the
expense of accuracy. Similarly, the smaller these values are, the more accurate
the results but the slower the convergence.

• Newton convergence issues with Krylov methods (because linear problem
solutions can only approximate) can be improved by using better
preconditioners.

• Set the Oversample parameter to a value greater than 1.0, such as 2.0 or 4.0.
However, remember that although this can often solve convergence problems, it
does so at the cost of computer memory and simulation time. For multiple-tone
harmonic balance simulations, make sure that the largest signal in the circuit
is assigned to Freq[1]. The simulator’s FFT algorithm is set up so that aliasing
errors are much less likely to affect Freq[1] than any other tone.

• When using a direct linear solver, the blocks of the Harmonic Balance Jacobian
inherit the Jacobian matrix ordering from the DC solution process. This matrix
ordering can greatly affect the efficiency of the Harmonic Balance Jacobian
factorization, and in some circuits show noticeable simulation slowdown. To
circumvent this issue, use a DC convergence mode that hasn’t changed, e.g.
DC_ConvMode=3.

• For non-convergence due to tight tolerances, monitor the residuals in the Status
Server window.

• Increase I_AbsTol if the circuit is converging to within a few pA but not quite
to
I_AbsTol=1pA

• Increase I_RelTol if the problem is with nodes associated with large currents

• Increase I_AbsTol if the small current nodes are the issue
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• Relax voltage tolerances for failure in the Newton update criterion

• The internal circuit simulator engine in ADS (Gemini) runs from a netlist. ADS
writes a netlist file (netlist.log) before invoking Gemini. The order of the
components and model definitions in the netlist determine the initial Jacobian
matrix ordering. This matrix ordering can affect the efficiency of the Jacobian
factorization and cause either a simulation slow down or non-convergence.

• For convergence problems due to errors in the component model equations
(incorrect derivatives, etc.) make sure ancient Berkeley MOSFET Level 1, 2, 3
are not the culprit and that the latest model version is used (especially BSIM3
models). Model problems can cause the Newton residual to hit a threshold
(greater than the convergence criteria tolerances) and stale the convergence
process or even exhibit random jumps (sudden increase in value). Set the
device’s Xqc parameter to a nonzero value to allow the simulator to use a
charge-based model for the gate capacitance. This often enables convergence,
but at the cost of extracting an extra SPICE model parameter.

Sweeps as Convergence Tools

Continuation methods provide a sequence of initial guesses that are sufficiently close
to the solution to assure Newton’s method convergence in Harmonic Balance. Sweeps
can be used to formulate a specialized continuation method geared towards the
particular circuit problem.

Sweep a circuit element that, when set to some different value, makes the circuit
more linear. For instance, in an amplifier circuit there may be a resistor that can be
used to lower the amplifier’s gain. The simulator may be able to find a solution to the
circuit under a low-gain condition. Then, if the component’s value is swept toward the
desired value, the simulator may be able to find a final solution. Start with a value
that works, and stop with the desired value. Also, select Restart, under the Params
tab. Usually, a better initial guess at each step helps the simulator to converge.

The two main ways to perform sweeps are:

• HB sweep within the HB controller. This is preferred for most sweeps, except
frequency.

• Parameter sweep using a separate sweep controller.
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Convergence and Samanskii Steps

The Samanskii steps can significantly speed up the solution process. However, using
an approximate Jacobian, particularly for a larger number of iterations, may result in
poor or even no convergence. The constant is used in two ways. First, it becomes a
more absolute measure when it is smaller. It then approaches the requirement that
each iteration reduces the relevant norm by one-third.

Decreasing the Samanskii constant beyond a certain point (which in turn depends on
the quality of the most recent Newton step) will make no difference. However, setting
the Samanskii constant to zero will effectively disable any Samanskii steps
altogether.

Increasing the Samanskii constant relaxes this requirements in general, but the
condition becomes more dependent on the quality of the standard most recent
Newton iteration. In other words, a more rapid convergence of the Newton step would
also require better convergence of the Samanskii steps.

Convergence and Arc-Length Continuation

Arc-length continuation is an extremely robust algorithm. If it fails, try all other
convergence remedies first before adjusting arc-length parameters

• MaxStepRatio controls the number of continuation steps (default 100)

• MaxShrinkage controls the size of the minimum step (default 1e-5)

• ArcLevelMaxStep limits the maximum step (default is 0, i.e. no limiting)

• ArcMinValue & ArcMaxValue define the range of the continuation parameter
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Circuit Envelope Simulation Controller
The Circuit Envelope controller is best suited for a fast and complete analysis of
complex signals such as digitally modulated RF signals. It combines features of time
and frequency-domain representation by permitting input waveforms to be
represented in the frequency domain as RF carriers, with modulation “envelopes”
that are represented in the time domain.

Circuit Envelope is highly efficient in analyzing circuits with digitally modulated
signals, because the transient simulation takes place only around the carrier and its
harmonics. In addition, its calculations are not made where the spectrum is empty.

• It is faster than Harmonic Balance, for a given complex signal Spice, assuming
most of the frequency spectrum is empty

• It does not compromise in Signal complexity, unlike time-varying HB or
Shooting Method Component accuracy, unlike Spice, Shooting Method, or DSP

• It adds physical analog/RF performance to DSP/system simulation with
real-time co-simulation with HP Ptolemy

• It is integrated in same design environment as RF, Spice, DSP, electromagnetic,
instrument links, and physical design tools

Advantages over Harmonic Balance

• In Harmonic Balance, if you add nodes or more spectral frequencies, the RAM
and CPU requirements increase geometrically. Krylov improved this, but it’s
still a limitation of Harmonic Balance because the signals are inherently
periodic.
6-10 Circuit Envelope Simulation Controller



• Conversely the penalty for more spectral density in Circuit Envelope is linear:
just add more time points by increasing TSTOP. The longer you simulate, the
finer your resolution bandwidth.

• Doing a large number of simple 1-tone HB simulations is effectively faster and
less RAM intensive than one huge HB simulation.

• With a circuit envelope simulation the amplitude and phase at each spectral
frequency can vary with time, so the signal representing the harmonic is no
longer limited to a constant, as it is with harmonic balance.

Limitations

1. More occupied spectrum than unoccupied spectrum.

You’re carrying more overhead with frequency-domain assumptions and
harmonics than necessary. Use SPICE.

2. Everything baseband. Depends.

• If everything linear, use AC/S-parameter (for noise or budget)

• If everything nonlinear or digital, use SPICE.

• If everything logic/behavioral, use PTOLEMY.

3. Occupied spectrum is relatively sparse.

If you can do what you want using Harmonic Balance, you should.
Post-processing, optimization, and yield are simpler and faster.

Simulation Process

1. Transform input signal

Each modulated signal can be represented as a carrier modulated by an
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envelope - A(t)*ejf(t). The values of amplitude and phase of the sampled
envelope are used as input signals for Harmonic Balance analyses.

2. Frequency Domain Analysis

Harmonic Balance analysis is performed at each time step. This process creates
a succession of spectra that characterize the response of the circuit at the
different time steps.

3. Time Domain Analysis

Circuit Envelope provides a complete non steady-state solution of the circuit
through a Fourier series with time-varying coefficients.
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4. Extract Data from Time Domain

Selecting the desired harmonic spectral line (fc in this case), it is possible to
analyze:

• Amplitude vs. Time (Oscillator start up, Pulsed RF response, AGC
transients)

• Phase (f) vs. Time (t) (VCO instantaneous frequency (df/dt), PLL lock time)

• Amplitude & Phase vs. Time (Constellation plots, EVM, BER)

5. Extract Data from Frequency Domain

By applying FFT to the selected time-varying spectral line it is possible to
analyze:

• Adjacent Channel Power Ratio (ACPR)

• Noise Power Ratio (NPR)
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• Power Added Efficiency

• Reference frequency feedthrough in PLL

• Higher order intermods (3rd, 5th, 7th, 9th)

Simulation Steps

1. Define baseband signal modulation

• Predefined sources

• Equations

• I & Q data vs. time data from DSP simulation

2. Define RF carrier frequencies, time step and duration of the simulation

3. Compute time-varying Fourier coefficients

4. Post-process and display results

OR

1. Define input signal(s) with modulation - amplitude, phase, frequency, I/Q, etc.

2. Define the time step

3. Simulator computes Fourier coefficients versus time:

4. Fourier transforms are computed to display frequency spectrum around any
tone (if necessary)

Typical Analyses

• Intermodulation distortion.

• Amplifier spectral regrowth and adjacent channel power leakage.

• Oscillator turn-on transients and frequency output versus time in response to a
transient control voltage.

• PLL transient responses.

• AGC and ALC transient responses.

• Circuit effects on signals having transient amplitude, phase, or frequency
modulation.
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• Amplifier harmonics in the time domain.

• Subsystems using modulation signals such as multilevel FSK, CDMA, or
TDMA.

• Third-order-intercept and higher-order intercept analyses of amplifiers and
mixers.

• Time-domain optimization of transient responses.

Typical Applications

Time Domain Data Extraction

Selecting the desired harmonic spectral line it is possible to analyze:

• Amplitude vs. Time

Oscillator start up

Pulsed RF response

AGC transients

• Phase vs. Time

VCO instantaneous frequency, PLL lock time

• Amplitude & phase vs. time

Constellation plots

EVM, BER

Frequency Domain Data Extraction

By applying FFT to the selected time-varying spectral line it is possible to analyze:

• Adjacent Channel Power Ratio (ACPR)

• Noise Power Ratio (NPR)

• Power added efficiency

• Reference frequency feedthrough in PLL

• Higher order intermods (3rd, 5th, 7th, 9th)
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LSSP Simulation Controller
The large-signal S-parameter simulation controller facilitates the computation of
large-signal S-parameters in nonlinear circuits.

Large-signal S-parameters are based on a harmonic balance simulation of the full
nonlinear circuit. Unlike S-parameters, large signal S-parameters can change as
power levels are varied because the harmonic balance simulation includes nonlinear
effects such as compression.
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XDB Simulation Controller
The XDB simulation controller computes the gain compression point of an amplifier
or mixer. It sweeps the input power upward from a small value, stopping when the
required amount of gain compression is seen at the output.
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Transient/Conv. Simulation Controller
The transient and convolution simulation controllers solve a set of
integro-differential equations that express the time dependence of the currents and
voltages of the circuit. The result of such an analysis is nonlinear with respect to time
and, possibly, a swept variable.

Use the Transient/Convolution controller to perform:

• SPICE-type transient time-domain analysis.

• Nonlinear transient analysis on circuits that include the frequency-dependent
loss and dispersion effects of linear models, or Convolution analysis.

A transient analysis is performed entirely in the time-domain. It does not account for
the frequency-dependent behavior of distributed elements.

A convolution analysis represents distributed elements in the frequency domain to
account for their frequency-dependent behavior.

Transient Simulation and Convergence

In Transient analysis a numerical integration algorithm is employed at each time
point to approximate the differential equations into algebraic equations. Integration
methods are used to replace the time derivative with a discrete-time approximation

Time Step Control Characteristics

Local Truncation Error

• Estimates the LTE made on every capacitor and inductor

• Determines the time step size to ensure the largest LTE remains within the
accepted tolerance
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• The estimated LTE is inversely proportional to TruncTol

• The accepted tolerance depends upon the relative and truncation tolerances set
for the curent and voltage. It is proportional to I_RelTol x TruncTol and
V_RelTol x TruncTol

Iteration-Count

• Determines the time step size based on the number of Newton iterations
required for previous time point

• No direct relationship between iterations and LTE

• Effectively controlled by Max time step (for linear circuits)

Fixed

• The time step is fixed and equal to Max time step

Break Points

• Generated by built-in independent sources whenever an abrupt change in slop
occurs

• Ensure that corners in waveforms are not missed

• ADS always places time points on a break point (except fixed time step)

• Backward Euler is used on time points that are the first time step after break
points

• The step size is reduced when time point is close to a break point

Transient Convergence Tips

1. For initial Transient analysis, try to use I_RelTol = V_RelTol = 1e-3, and tighten
these values only when higher accuracy is needed. Simulation will run much
faster with these setting compared to 1e-6.

2. Transient analysis convergence problems are often caused by jumps in the
solution. This most often occurs in circuits with overly simplified models that
exhibit positive feedback, or when the circuit contains nodes that do not have a
capacitive path to ground. Add a small capacitor from the troublesome node to
ground and give a complete capacitance model when specifying the nonlinear
device model parameters.
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3. Generally analog circuits are sensitive to truncation error due to their relative
long time constants. Use LTE time step control to ensure the accuracy of the
results.

4. Backward Euler (Gear1 or Mu=0 in Trapezoidal) and Gear2 are stable for all
stable and some unstable differential equations. However, trapezoidal rule are
stable only on stable differential equations. Switch to Gear1 or Gear2 when
trapezoidal rule fails on unstable differential equations.

Typical Convergence Problems

Capacitor model problems

• Use simplified device models that do not include capacitance model or
incomplete capacitance model give a complete capacitance model when
specifying nonlinear device model parameters, in junction capacitance, include
both depletion (at least) and diffusion capacitances

• Discontinuous jumps in waveforms when circuit contains nodes have no
capacitive path to ground add small capacitor to ground or specify Cmin

• Capacitance model does not conserve charge GaAsFET Statz’s, MOSFET
Meyer’s capacitance models switch to charge based model

• Large floating capacitors that are similar to the small-floating resistor problem
in DC (finite precision problem) check capacitance unit, use smaller capacitance

• Discontinuous capacitance models in user defined model, SDD device fix the
model

Slow Transient analysis

• Make sure I_RelTol and V_RelTol are set to 1e-3 or not set at all

• Decrease these values when higher accuracy is needed

Oscillator circuit does not oscillate

• Apply a short pulse at the beginning of the simulation

• Avoid using Gear2 or backward Euler
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Circuit exhibits ringing or divergence

• Reduce Mu value from 0.5 toward 0 if trapezoidal rule is used

• Use Gear1 or Gear2

Circuit does not converge at first time point

• Reduce Min time step

Convergence Hints

Add break points

Use piecewise linear source to add break points to the region where the waveform
changes abruptly

Reduce max time step

Ensure enough time points for sharp edges

Increase Max iterations per time step

Increase to 50 or more to increase the possible number of Newton iterations on each
time step

Increase I_AbsTol

Try 1e-10 instead of the default 1e-12

Relax TruncTol

Increase this value 10 times or more to relax LTE tolerance

Relax I_Reltol and V_Reltol

Increase to 1e-3 to relax Newton convergence tolerance as well as LTE tolerance

Try different integration methods

Switch from trapezoidal to Gear’s method
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Using Convolution

• Don’t set any convolution parameters (let the adaptive algorithm figure it out)

• Set ImpMaxFreq first (larger than signal bandwidth)

• Set convolution parameters on component, not controller, when possible

• Don’t allowed measured data to be extrapolated (either set ImpMaxFreq or
provide more data)

Convolution Modeling for Time-Domain Simulation

• In time-domain simulation, simulate devices that can only be defined in the
frequency domain

• Transmission lines with dispersion

• Devices with frequency-dependent loss

• Measured frequency-domain data

• Convolution is the key

• Inverse Fourier transform of frequency-domain data produces the impulse
response h(t)

• The impulse response is convolved with time-domain signal

Time and Frequency Range

• Impulse response is computed from the inverse Fourier transform of
frequency-domain response frequency is uniformly sampled from 0 to some
upper value

• Upper frequency sets the time-domain spacing of the impulse response

• Frequency spacing sets the length of the impulse response

Adaptive Impulse Response Calculation

• Estimate of system bandwidth is made from source frequencies and rise times -
initial guess at fmax

• Build a trial impulse response with 32 timepoints
very coarse frequency spacing
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• Build a second impulse response with 64 timepoints
less coarse frequency spacing

• Keep doubling the number of timepoints until a good impulse response is
obtained
increase fmax, decrease Df

• y11 and y12 may be sampled with different fmax and Df

• Adaptive calculation is only done if ImpDeltaFreq is not specified
don’t set ImpDeltaFreq if you don’t have to

Good Impulse Responses

• Compare impulse responses with N and 2N points. The second impulse
response is twice as long in time domain and has half the frequency spacing.

• An impulse is considered “good” when no appreciable energy is present in the
second half of the impulse response if energy is present in the second half,
implies either that the impulse is not long enough or it is noncausal

• If not good, Controller keeps doubling the length

• Controller also tries doubling the maximum frequency, giving smaller impulse
timesteps

Interpolation

• The impulse response is sampled with a uniform timestep, but is not
guaranteed to match the simulation timestep. The simulation may even be
using a variable timestep.

• Interpolate the signal v(t) to match the timepoints in the impulse response
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• Don’t interpolate the impulse response because the Fourier transform of the
interpolated impulse response would no longer match the original frequency
response

Impulse Evaluation

• Signal response at time zero extends back to minus infinity

• Evaluate the integral as a sum

Solving an Invalid Impulse Response

This is the most commonly encountered problem during convolution. It does not
necessarily imply noncausality but means that significant energy is present in the
second half of the impulse response. In addition, simulation results may or may not
be valid.

• Set ImpMaxFreq or ImpDeltaFreq. Set ImpMaxFreq first, typically only for
measured data.

• For every component that generates this message, fix each component one at a
time to simplify the design.
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Viewing an Impulse Response

• In an S-parameter simulation, analyze over the given frequency spacing and
maximum frequency
inverse Fourier transform the response by plotting ts(x)

• In the time domain, apply an impulse and simulate
plot the transient result
the pulse risetime is used to set fmax and thus can influence the impulse
response

Setting ImpMaxFreq and ImpDeltaFreq

Generally a good impulse response can be found without manually setting
ImpMaxFreq and ImpDeltaFreq

• If ImpMaxFreq is set, the adaptive algorithm tries different lengths but doesn’t
modify fmax

• If ImpDeltaFreq is set, the adaptive algorithm is disabled and the impulse is
computed from ImpDeltaFreq and ImpMaxFreq

• Set ImpMaxFreq on the component, then set ImpDeltaFreq on component if
necessary, and finally, set ImpMaxFreq on the transient controller if necessary

• For transmission lines, set ImpMaxFreq to at least n/td, where td is the delay
time and n is a small integer (2-3)

• For lowpass and bandpass filters, set ImpMaxFreq to at least twice the upper
passband edge

Measured Data with S2P Component

• The algorithm that computes the impulse response has no special knowledge of
the component it’s working on and assumes data is available at any desired
frequency. It has no knowledge of flow and fhigh or frequency spacing of
measured data

• S2P interpolates and extrapolates data as needed

• Be sure to supply good data to prevent dangerous extrapolation extends down
to DC and up to fmax

• Set ImpMaxFreq on S2P component to match frequency limits in datafile (avoid
extrapolation)
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• Typically there is not enough frequency-domain data in the S2P file for use in
the simulation

Given a pulse with a risetime of tr, the equivalent bandwidth is 2.2/tr (0.1 ns
risetime represents a 22 GHz bandwidth)

Package models typically must be measured up to 10x higher than the signal
frequency to represent transmission line effects well

Solving a Noncausal Impulse Response

This is the second most commonly encountered problem during convolution. The
Time-domain simulation starts at time zero and moves forward in time, computing
the value of next timepoint from all previous timepoints. And the Controller deals
with this by introducing a delay to force causality.

Length of delay set to ImpNoncausalLength (default=32) with timestep set by
default ImpMaxFreq

Simulation results will not be accurate because of the added delay, especially if the
delay is added in a critical timing or phase path.

All physically realizable devices are causal (the output is dependent only on past
states and not any future states) while noncausal devices are nonphysical. Some ADS
components, user-defined data or equations may be noncausal.

• Frequency-dependent real part with constant imaginary part, for example
resistance as a function of frequency without any reactance

• Constant real and constant non-zero imaginary part

• Negative time delays

• INDQ, CAPQ, PLCQ, SLCQ have problems in some modes
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Chapter 7: Additional Resources
Use the following ADS resources to optimize your design tasks.

Documentation
The Agilent EEsof Product Documentation home page on the Web includes
information and links to complete documentation for all EEsof product. For ADS it
currently provides documentation for ADS 1.5 onward.

The documentation provided on the website includes the following.

• Release Notes list of known problems.

• New highlights of what is new in the current release.

• Manuals  descriptions and links to the complete documentation set.

• Examples descriptions of examples used to solve real-life design tasks.

• DesignGuides descriptions and links to application-focussed DesignGuide
documentation.

• Quick Start web-based version of the Quick Start manual.

• Search global search of ADS documentation.

• PDF Files printable files for all ADS documentation.

The Agilent EEsof Product Documentation Web site is at

http://www.agilent.com/find/eesof-docs/

Website
The Agilent EEsof EDA home page on the Web includes information and links to the
following resources.

• EDA library articles, papers, application notes, and other publications.

• Foundry Partners links to leading IC manufacturers who provide design
libraries for ADS.

• Success Stories  what real users, large and small, have to say about their
successes with ADS.
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Additional Resources
• Training Classes current list of training courses being offered worldwide.

• Applications applications information including downloadable example files
and publications.

• Knowledge Center database of information, discussions, and downloads.

The Agilent EEsof EDA Web site is at

http://www.agilent.com/find/eesof/

Support Contacts
Agilent EEsof worldwide technical support is available Monday through Friday. The
toll-free North America hotline is open 6:00 am to 5:00 pm PT. Throughout Europe,
the localized Online Technical Support Centers are open 8:30 am to 5:30 pm, local
time; throughout Asia, the localized Customer Response Centers are open 9:00 am to
6:00 pm, local time.

The e-mail addresses for the various regions are listed below. However, for both the
regional e-mail addresses and local telephone numbers for more than 25 countries,
please refer to the Agilent EEsof Support Web site at

http://www.agilent.com/find/eesof-supportcontact/

North America

Phone: 1 800 47 EEsof (473-3763) · Fax: 818-879-6465

e-mail: eesof_support@agilent.com

Europe: e-mail: eesof-europe_support@agilent.com

Japan: e-mail: edasupport@jpn.agilent.com

Korea: e-mail: eesof_korea@agilent.com

Asia: e-mail: eesof-asia_support@agilent.com
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