Important Information

Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected.

In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THEREFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against National Instruments must be brought within one year after the cause of action accrues.

National Instruments shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

Trademarks

Product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, partnership, or joint-venture relationship with National Instruments.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help» Patents in your software, the patents.txt file on your CD, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT INJURY TO A HUMAN.
(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE, FITNESS OF COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER COLLECTIVELY TERMED "SYSTEM FAILURES"). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS, BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS. THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
Contents

About This Manual
Conventions ................................................................................................................... vii
Related Documentation ............................................................................................... vii

Chapter 1
Introduction to SignalExpress
SignalExpress for the Design Lab ............................................................................... 1-1
Extending SignalExpress Projects with LabVIEW ..................................................... 1-2
SignalExpress and the Express Workbench ................................................................. 1-2

Chapter 2
Installing SignalExpress
Limitations of the SignalExpress Evaluation Software ............................................... 2-1
Minimum System Requirements ................................................................................. 2-1
Installing SignalExpress ............................................................................................. 2-2

Chapter 3
Working with Projects
Loading a Project ....................................................................................................... 3-1
Running a Project and Displaying Signals ................................................................ 3-2
Configuring a Step ...................................................................................................... 3-4
Moving and Deleting Steps ....................................................................................... 3-7
Handling Errors and Warnings ................................................................................ 3-8

Chapter 4
Working with Signals
Graphing Signals ....................................................................................................... 4-1
Importing a Signal from a File .................................................................................. 4-3
Aligning and Comparing Signals ............................................................................. 4-4
Signal Types in SignalExpress .................................................................................. 4-6
Exporting and Printing Signals ................................................................................ 4-7
   Exporting Signals to Microsoft Excel ................................................................. 4-7
   Printing Signals ................................................................................................... 4-7
   Saving Signals as Images .................................................................................... 4-7
## Contents

### Chapter 5
**Performing Sweep Measurements**
- Defining Sweep Ranges and Outputs ......................................................... 5-1
- Plotting Sweep Results ................................................................................. 5-4
- Running Multi-Dimensional Sweeps .......................................................... 5-5

### Chapter 6
**Extending SignalExpress Projects with LabVIEW**
- Importing LabVIEW VIs into SignalExpress as Steps .............................. 6-1
- Converting SignalExpress Projects to LabVIEW Block Diagrams ............. 6-4

### Chapter 7
**Where to Go from Here**
- SignalExpress Sample Projects ................................................................. 7-1
- Using Hardware with SignalExpress .......................................................... 7-1
- Web Resources ......................................................................................... 7-1

### Appendix A
**Technical Support and Professional Services**
About This Manual

Use this manual to familiarize yourself with SignalExpress interactive measurements and the basic SignalExpress features that you use to acquire and analyze signals.

This manual contains exercises that help you begin working with SignalExpress. These exercises teach you how to run projects, configure steps, work with signals, configure sweep measurements, and extend SignalExpress with LabVIEW.

Conventions

The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options to a final action. The sequence File→Page Setup→Options directs you to pull down the File menu, select the Page Setup item, and select Options from the last dialog box.

bold Bold text denotes items that you must select or click in the software, such as menu items and dialog box options. Bold text also denotes input and output names, parameter names, dialog boxes, sections of dialog boxes, and menu names.

italic Italic text denotes variables or cross references.

monospace Text in this font denotes text or characters that you should enter from the keyboard. This font is also used for the proper names of disk drives, paths, directories, programs, subprograms, subroutines, device names, functions, operations, variables, filenames, and extensions.

Related Documentation

Refer to the NI Express Workbench Help, available by selecting Help→Express Workbench Help, for more information as you read this manual.
Introduction to SignalExpress

National Instruments provides innovative solutions for scientists and engineers to build automated measurement systems based on industry-standard computers and platforms. National Instruments develops robust, industry-leading programming environments for automating measurement systems, such as LabVIEW for graphical development, LabWindows™/CVI™ for ANSI C programming, and Measurement Studio for Microsoft Visual Studio programming. You can use these programming tools with National Instruments measurement hardware and interfaces to traditional instruments to build custom advanced virtual instrumentation systems.

SignalExpress optimizes virtual instrumentation for design engineers by offering instant interactive measurements that require no programming. You can use SignalExpress interactively to acquire, generate, analyze, compare, import, and save signals. You can compare design data with measurement data in one step. SignalExpress extends the ease of use and performance of virtual instrumentation to those who must acquire or analyze signals without programming applications. You also can extend the functionality of SignalExpress by importing a custom virtual instrument (VI) created in LabVIEW or by converting a SignalExpress project to a LabVIEW block diagram so you can continue development in the LabVIEW environment.

SignalExpress for the Design Lab

SignalExpress is ideal for engineers who use an Electronic Design Automation (EDA) software tool to design and simulate a developing product. Although design engineers primarily focus on designing products, often designers also must perform measurements. For example, the typical designer must do the following:

- Complete designs and validate them rapidly against prototypes
- Invest time in designing rather than programming
- Perform measurements to verify that prototypes work as expected
- Perform detailed characterization and validation measurements on designs
You can use SignalExpress to import signals from a SPICE simulator and compare them with physical measurements on the same graphs. You can configure sweep measurements to measure the performance of a design across frequency, amplitude, or supply ranges. You also can export signals to ASCII files or spreadsheet applications such as Microsoft Excel for further analysis. You can accomplish all these actions within an interactive virtual instrumentation environment without needing to program.

**Extending SignalExpress Projects with LabVIEW**

You can extend the functionality of SignalExpress with LabVIEW in the following ways:

- You can build VIs with LabVIEW and import them into SignalExpress to expand the built-in measurement options.
- You can convert SignalExpress projects to LabVIEW block diagrams to continue developing the application. By doing so, you can use the interactive tools in SignalExpress to define measurement procedures, then convert the sequence into a LabVIEW block diagram to build automated test applications.

Refer to Chapter 6, *Extending SignalExpress Projects with LabVIEW*, for more information about these two options.

**SignalExpress and the Express Workbench**

The Express Workbench is an interactive framework that can host multiple National Instruments tools and assistants. SignalExpress is the first interactive software tool hosted within the Express Workbench. Other tools further extend the capabilities of the Express Workbench. Refer to the National Instruments Web site at [ni.com/info](http://ni.com/info) and enter the info code expwrk for the most up-to-date information on the Express Workbench.
Installing SignalExpress

You can use the SignalExpress Development CD or the SignalExpress Evaluation CD to install SignalExpress and complete the exercises in this manual.

Limitations of the SignalExpress Evaluation Software

The SignalExpress Evaluation CD provides full functionality for 30 days. After 30 days, the SignalExpress evaluation version runs with the following limitations:

- You can no longer save projects, so you cannot convert projects into LabVIEW block diagrams.
- You can run projects for only 10 minutes per session.

Refer to the National Instruments Web site at ni.com/signalexpress to purchase a licensed copy of SignalExpress.

Minimum System Requirements

SignalExpress requires a minimum of 128 MB of RAM and a Pentium III or later or Celeron 600 MHz or equivalent processor, but National Instruments recommends 256 MB of RAM and a Pentium 4 or equivalent processor.
Chapter 2  Installing SignalExpress

Installing SignalExpress

Complete the following steps to install SignalExpress on Windows 2000/NT/XP.

Note  If you want to import LabVIEW VIs into SignalExpress or convert SignalExpress projects to LabVIEW block diagrams, you must install LabVIEW 7.1 or later before you install SignalExpress.

1. Disable any automatic virus detection programs before you install. Some virus detection programs interfere with the installation program.
2. Log on as an administrator or as a user with administrator privileges.
3. Insert the SignalExpress Development or Evaluation CD and follow the instructions that appear on the screen.
   By default, SignalExpress installs in the Program Files\National Instruments\SignalExpress directory.
4. After installation, check the hard disk for viruses and enable any virus detection programs you disabled.

The example projects you use with this manual are located in SignalExpress\Examples\Tutorial. The solutions for each exercise are located in SignalExpress\Examples\Tutorial\Solutions.

If you use SignalExpress with National Instruments data acquisition or modular instrumentation hardware, you must install NI-DAQmx 7.3 or later, NI-SCOPE 2.7 or later, or NI-FGEN 2.2 or later. SignalExpress includes a National Instruments Driver CD that includes these drivers.
Working with Projects

You can use SignalExpress to define measurement procedures by adding and configuring steps in an interactive measurement environment. A step is a configurable function that acquires, generates, analyzes, loads, or stores signals. Steps process input signals and produce output signals. You can configure the operation of a step by specifying values in a configuration view. A saved sequence of configured steps is a SignalExpress project.

This chapter teaches you about the basic layout of SignalExpress. You learn how to load and run existing projects and how to configure steps in these projects.

Loading a Project

Complete the following steps to load a sample project in SignalExpress.

1. Launch SignalExpress.
2. If SignalExpress does not open in the factory-default configuration, select View»Data View to display the Data View.
3. Select File»Open, navigate to the SignalExpress\Examples\Tutorial directory, and double-click the First Project.wbp workbench project. Workbench projects refer to the Express Workbench framework in which SignalExpress resides.
4. Examine the window that appears, as shown in Figure 3-1, to learn about different components of SignalExpress.
The left pane is the Project View, which presents the order of operations, or steps, for the project. The right pane is the Data View, which displays the signal that the project generates and analyzes.

**Running a Project and Displaying Signals**

SignalExpress has two execution modes—Run and Run Once. When you click the **Run** button, SignalExpress executes all steps in the project continuously until you click the **Stop** button. The **Stop** button appears in place of the **Run** button as a project runs. While the steps in the project execute, the Data View updates continuously. While the project runs, you can change the measurement configurations and view the results.
immediately. If you modify the configuration of steps while a project runs, SignalExpress gives you direct, immediate feedback on the changes you make. When you click the **Run Once** button, SignalExpress executes all steps in the project one time.

Complete the following steps to run the sample project and display signals.

1. Click the **Run** button, shown at left, to execute all steps in the project continuously.

The project loads a signal from a text file and performs two operations on the signal—an amplitude and levels measurement and a distortion measurement. The Amplitude and Levels step and the Distortion step perform these measurements, respectively. When you run a project, steps analyze input signals and generate new output signals as a result of the analysis. In this project, the Load from ASCII step loads a distorted sine wave, the Amplitude and Levels step and the Distortion step analyze the sine wave, and both steps return new outputs. In the Project View, SignalExpress indicates inputs with red arrows and outputs with blue arrows.

The graph in the Data View still contains the loaded signal, which is a time-domain signal. Graphs display time-domain, frequency-domain, or x-y signals.

2. Click the **exported spectrum** output signal of the Distortion step in the Project View and drag it to the Data View to display the signal.

SignalExpress creates a new graph in the Data View. SignalExpress does not display the **exported spectrum** signal on the same graph as the time-domain signal because the **exported spectrum** signal is a frequency-domain signal. SignalExpress automatically recognizes different types of signals and renders them in the appropriate displays.

3. Select **Help»Express Workbench Help**, click the **Search** tab, and enter "signal types" to refer to the *NI Express Workbench Help* for more information about signal types. The help provides information about using SignalExpress functionality such as projects, steps, and signals.

4. Click the **dc** output of the Amplitude and Levels step and drag it to the Data View to display the measurement.

SignalExpress creates a table to display the scalar measurement from the **dc** output.

5. Drag the **rms** output to the table to display the scalar RMS measurement.

SignalExpress creates a new row in the table to display the second measurement. The project should appear as shown in Figure 3-2.
Configuring a Step

A step is a configurable function that acquires, generates, analyzes, loads, or stores signals. Steps process input signals and produce output signals. You can configure the operation of a step in SignalExpress by specifying values in the Step Setup dialog box, or configuration view, for that step. While a project runs, you can modify the configuration of steps to view immediate feedback on the changes and adjust the measurements until you achieve the results you need.

Complete the following steps to configure the Distortion step and the Amplitude and Levels step.

1. Double-click the Distortion step in the Project View. The Step Setup dialog box for the Distortion step appears, as shown in Figure 3-3. If the Step Setup dialog box is docked, click the Dock button, shown at left, on the toolbar to undock the dialog box.
Chapter 3  Working with Projects

Figure 3-3. Distortion Step Setup Dialog Box

On the Configuration tab, the settings indicate that the Distortion step receives a time-domain waveform signal as an input, performs a power spectrum on the signal to convert it to the frequency domain, and computes the total harmonic distortion (THD) and fundamental frequency of the signal. The step generates three measurements as outputs—the spectrum, the THD, and the fundamental frequency of the original time-domain waveform input.

2. If the context help does not appear on the right side of the Step Setup dialog box, click the Show Help button, shown at left, to display complete reference information about the step. The upper half of the context help displays information about the step, and the lower half of the context help displays information about an object when you move the cursor over the object.

3. On the Configuration tab, select Fundamental Tone from the Export signals (THD) pull-down menu.

The operation of the step changes from displaying the frequency-domain spectrum of the entire input signal to displaying
only the frequency spectrum of the fundamental tone of the input signal. The signals in the top half of the Step Setup dialog box update to reflect the change you made.

4. Select **Harmonics Only** from the **Export signals (THD)** pull-down menu.

The step changes to export only the spectrum of the harmonic signals from the input signal. Both the output signal of the Distortion step and the graph on the Data View update to reflect the change you made.

5. Click the Amplitude and Levels step in the Project View.

The Step Setup dialog box changes from displaying the configuration of the Distortion step to displaying the configuration of the Amplitude and Levels step.

6. Click the **Input/Output** tab to display the list of possible inputs and outputs for this step, as shown in Figure 3-4.

7. Place checkmarks in the **Export +peak value**, **Export -peak value**, and **Export peak-peak value** checkboxes to configure the Amplitude and Levels step to return three additional measurements.

   Three additional outputs appear in the Project View.
8. Click the Close button, shown at left, in the Step Setup dialog box to close the Amplitude and Levels configuration view.

9. Drag the three new outputs from the Project View to the table to display the scalar measurements.

10. Click the Stop button, shown at left, to stop the project.

   When you click the Stop button, the project stops running after completing the current cycle of operations, or the current iteration. Clicking the Abort button completely stops the project without finishing the current iteration.

11. Select File»Save As and save the project as My First Project.wbp in the SignalExpress\Examples\Tutorial directory.

12. Select File»Close to close the project.

## Moving and Deleting Steps

The steps in SignalExpress projects depend on input data, which means steps can operate only on signals exported from previous steps in the Project View. When you click the Input signal pull-down menu in the Step Setup dialog box of a step, the menu displays only compatible signals exported from a previous step. When the output of a step becomes the input of another step, the steps become dependent on each other, and the two steps execute sequentially at the same rate. The first step generates an output signal that the second step must receive as an input before the step can execute.

You can move a step within a project by dragging it up or down in the Project View. You can delete a step by right-clicking it in the Project View and selecting Delete from the shortcut menu. However, when you move or delete a step, the status of signals in the project changes. For example, if you delete a step that generates output signals, the operation of the project breaks if any of the deleted output signals are inputs for other steps, and an error indicator appears in the Project View. If you move a step lower in the project, the output signals of the step are not available as inputs to any of the previous steps.

You also can cut, copy, and paste steps within a project by pressing the <Ctrl-X>, <Ctrl-C>, and <Ctrl-V> keys, respectively, or by right-clicking a step in the Project View and selecting Cut, Copy, Paste Before, or Paste After from the shortcut menu.
Handling Errors and Warnings

If an error occurs while a project runs, an error indicator, shown at left, appears in the Project View on the step that encountered the error. Double-click the step with the error to display an error description across the bottom of the Step Setup dialog box. Click the Details button to the right of the error description to display the full error description.

SignalExpress logs all errors and warnings in the Event Log while a project runs. To display the Event Log, select View » Show Event Log and click the Event Log tab in the Data View area. Refer to the NI Express Workbench Help for more information about errors and warnings by selecting Help » Express Workbench Help, clicking the Search tab, and entering errors.
Working with Signals

You can use SignalExpress to generate and analyze signals to evaluate designs without programming. This chapter teaches you how to work with signals in SignalExpress, including how to plot signals on graphs, import signals from a file, interactively align and compare two signals, and save signals to a file.

Graphing Signals

Complete the following steps to plot signals in a sample project and examine the signals visually using cursors.

1. Select **File»Open**, navigate to the SignalExpress\Examples\Tutorial directory, and double-click Signals.wbp. This project configures the Create Signal step to create a square wave signal and the Filter step to perform a lowpass Butterworth filter.

2. Drag the **step signal** output of the Create Signal step to the Data View.

3. Drag the **filtered step** output of the Filter step to the Data View.

   You can plot signals of the same signal type on the same graph. Both the **step signal** and the **filtered step** signals are time-domain signals, so they appear on the same graph. If you want to plot signals of different types, drag the signals to the same graph and SignalExpress creates a new graph.

4. Click the **Add Display** button, shown at left, on the toolbar to create a new graph.

5. Drag the **filtered step** output of the Filter step to the new graph.

6. Right-click the new graph and select **Cursors** from the shortcut menu to display two interactive cursors, as shown in Figure 4-1.
As you drag the cursors, SignalExpress displays the x and y values of the cursors in the cursor table at the bottom of the Data View.

7. Right-click the graphs to view other operations in the shortcut menu. If you have multiple signals on a single graph and one signal obscures another, you can change the order of the signals. If you run a project continuously but you want to view the data from a particular execution iteration, you can pause the display by right-clicking the Data View, selecting **Display Update** from the shortcut menu, and selecting **Always Update** to remove the checkmark next to it. You also can add or remove displays and add or remove signals.

8. Select **File»Save As** and save the project as **My Signals.wbp** in the **SignalExpress\Examples\Tutorial** directory.
Importing a Signal from a File

You can import signals from standard file formats such as ASCII comma- or tab-delimited files and LabVIEW measurement data files (.lvm). You also can import signals from simulated results of EDA tools such as SPICE simulators.

Complete the following steps to import a signal from a file.

1. Right-click the Project View and select Signal Input/Output> Load/Save Signals>Load from ASCII from the shortcut menu.
2. Click the browse button, shown at left, in the Step Setup dialog box, navigate to the SignalExpress\Examples\Tutorial directory, and double-click StepResponse.txt. This step parses an ASCII file and displays the signals in the file. In the File preview section, column 1 shows the time stamp data, and column 2 shows the actual voltage values of the signal.
3. Click the Import Signals tab to display the available signals in the file.
4. Place a checkmark in the Column 2 checkbox to import that signal, and remove the checkmark from the Column 1 checkbox.
   The Step Setup dialog box displays a preview of the signal in the Imported Signal section.
5. Select Column 1 from the Input X values pull-down menu to set the x-axis data of the waveform to the appropriate values.
6. Click the Close button to close the Step Setup dialog box.
7. Right-click the Column 2 output in the Project View and select Rename from the shortcut menu.
8. Enter step response and press the <Enter> key to rename the output.
9. Drag the step response output of the Load from ASCII step to the lower graph. A dialog box appears because the two signals come from different sources and run at different rates.
10. Click the Yes button to display both signals on the same graph. The filtered step signal resembles the rising edge of the step response output, as shown in Figure 4-2.
Aligning and Comparing Signals

Although the filtered step signal and the step response output both show an overshoot in the rising edge, assessing the similarity between the two is difficult because the signals come from different sources and vary in amplitude and timing. However, you can use the Interactive Alignment step to align and compare two signals, so you can choose which type of information you want to export from the operation to use in the project.

Complete the following steps to align two signals in the MySignals.wbp project.

1. Right-click the step response output and select Send To > Processing > Interactive Alignment from the shortcut menu to pass the step response signal from the Load from ASCII step to the Interactive Alignment step.

11. Select File > Save to save the project.
The step selects the two most recent signals from the project to use as inputs and displays the signals on the graph of the Step Setup dialog box, as shown in Figure 4-3.

![Interactive Alignment Step Setup Dialog Box]

When you add a step to a project, SignalExpress selects input signals based on the signal types the step can accept. For example, the Interactive Alignment step can operate only on time-domain waveform signals. Therefore, the step selects as inputs the last two time-domain signals created in the project. To change the input signals for a step, select different signals from the pull-down menu of compatible signals in the Input/Output tab of the Step Setup dialog box.

2. Click the red signal and drag it within the graph.

You can drag, expand, and contract signals on the graph.
3. Try to align the rising edges of the two signals by dragging a signal within the graph. Click a signal to set an anchor point and press and hold the <Alt> key to stretch the signal around that anchor point in the x and y directions.

On the Alignment tab of the Step Setup dialog box, the step computes and displays the x and y gain and offset values you need to achieve alignment specifications as you drag the signals.

4. Select Auto - Step from the Mode pull-down menu to align the signals. SignalExpress bases this alignment mode on built-in algorithms.

The center graph in the Step Setup dialog box displays the difference between the two signals.

5. On the Input/Output tab, place a checkmark in the Export aligned signals checkbox to add the signals to the outputs of the step.

6. Click the Close button to close the Step Setup dialog box.

7. Click the Add Display button, shown at left, to add a third graph.

8. Drag the aligned reference and aligned test outputs of the Interactive Alignment step to the new graph to view the aligned signals.

9. Select File»Save to save the project.

Signal Types in SignalExpress

Some steps, such as the Arithmetic step, can operate on multiple signal types. For example, you can use the Arithmetic step to operate on time-domain or frequency-domain waveforms. The Arithmetic step changes behavior based on the type of input signals you select for the step. For example, if you add two time-domain signals, SignalExpress adds only their amplitudes. However, if you add two frequency-domain phase signals, SignalExpress adds the appropriate phase shift.

Refer to the NI Express Workbench Help for more information by selecting Help»Express Workbench Help, clicking the Search tab, and entering "signal types".
Exporting and Printing Signals

SignalExpress offers several documentation features so you can continue analysis in another software application, such as Microsoft Excel or the report generation tool NI DIAdem. These features can help you document the data from SignalExpress in reports. You can print graphs of signals and export or save signal data to view it in spreadsheet applications.

Complete the following steps to save a signal to a file.

1. Click the Add Step button and select the Save to ASCII step from Signal Input/Output»Load/Save Signals.
2. Click the Signals tab in the Step Setup dialog box and select filtered step from the Input Data pull-down menu.
3. On the File Settings tab, save the file to SignalExpress\Examples\Tutorial\filtered signal.txt.
4. Select Overwrite from the If file already exists pull-down menu.
5. Select Generic ASCII from the Export file type pull-down menu.
   You can use a Load/Save Signals step to save data to a file every time the project runs.
6. Click the Close button to close the Step Setup dialog box.
7. Select File»Save to save the project.
8. Select File»Close to close the project.

Exporting Signals to Microsoft Excel

To export signal data to Microsoft Excel, launch Excel and drag the output signal of a step in SignalExpress to an Excel spreadsheet.

Printing Signals

To print an image of a graph, right-click the Data View and select Export»Print Display from the shortcut menu.

Saving Signals as Images

To save an image of a graph as a .png file, right-click the Data View and select Export»Save as Image from the shortcut menu. You can import a .png file into Microsoft Word or other documentation tools.
Performing Sweep Measurements

You can use SignalExpress to automate measurements to characterize and validate designs by creating sweep operations. You can use the sweep measurements to gather data from designs over a range of conditions to document the performance of the designs. For example, you can use sweep operations to vary the frequency of a stimulus signal or vary the level of a supply voltage while taking measurements to characterize designs.

This chapter teaches you how to set up sweep operations using the Sweep step in SignalExpress. You learn how to characterize the performance of a filter by sweeping through a range of frequency values and measuring the output of the filter. You also learn how to display sweep results and perform multi-dimensional sweeps for more complex measurements.

Defining Sweep Ranges and Outputs

You can use the Sweep step in SignalExpress to define automated measurements for complex, repeatable sweep operations.

Complete the following steps to define a frequency range in a sample project to sweep through a filter.

1. Select File → Open, navigate to the SignalExpress\Examples\Tutorial directory, and double-click Sweep.wbp.

2. Click the Run button, shown at left, to run the project.

The project generates a sine wave stimulus signal using the Create Signal step, passes it through a bandpass elliptic filter using the Filter step, measures the RMS level of the filter output using the Amplitude and Levels step, and converts the level to decibels (dB) using the Formula step. The Filter step acts as a simulated unit under test, so the project uses no hardware. However, you also can sweep physical signals generated from a National Instruments arbitrary waveform generator, function generator, or multifunction I/O (MIO) device.
3. Click the Add Step button, shown at left, and select Tests/Operations»Sweep.

4. Click the Add button in the Step Setup dialog box to display the list of sweep parameters from each step in the project, as shown in Figure 5-1.

![Sweep Parameter Selection Dialog Box](image)

**Figure 5-1.** Sweep Parameter Selection Dialog Box

5. Select the Frequency parameter under Create Signal and click the OK button.

6. On the Sweep Configuration tab, select Exponential from the Type pull-down menu.

7. Enter 1k in the Start Frequency (Hz) field, and enter 40k in the Stop Frequency (Hz) field.

8. Enter 150 in the # points field.

The Sweep Configuration tab should appear as shown in Figure 5-2.
You used the Sweep step to specify a range of values to iterate through the Frequency parameter of the Create Signal step. The Create Signal step uses the defined frequency range to generate a sine wave at each of these frequencies. However, you can use the Sweep step to sweep any sweepable parameter value of any sweepable step in a project.

9. Click the Sweep Output tab.
10. Click the Add button to display the list of sweep outputs from each step in the project.
11. Select the response amplitude in dB output under Formula (Scalar) and click the OK button to plot this measurement against the swept Frequency parameter.
12. Click the Close button, shown at left, to close the Step Setup dialog box.

The Sweep step creates a loop around all the steps in the project to include all the steps in the sweep operation.
Plotting Sweep Results

Complete the following steps to run the sweep measurement.

1. Click the **Run Once** button, shown at left, to execute the sweep measurement.

   The **stimulus signal** output on the graph iterates through the specified range of frequencies.

2. Drag the **response amplitude in dB vs. Frequency** signal from the bottom of the Sweep loop to the Data View to display the output of the sweep.

   SignalExpress creates a new graph. The data from a sweep operation is an x-y array that requires a separate graph, as shown in Figure 5-3.

![Figure 5-3. Sweep.wbp](image-url)
3. Click the Run Once button again to execute the sweep.
   The frequency response of the Filter step plots on the new graph while the project runs. The graph displays the transfer function of the filter, or the amplitude output expressed in decibels versus the frequency.

4. Double-click the Filter step to display the filter specifications in the Step Setup dialog box.
   The frequency response of the filter in the Filter Magnitude Response graph matches the graph in the Data View.

5. Click the Close button to close the Step Setup dialog box.

6. Select File→Save As and save the project as My Sweep.wbp in the SignalExpress\Examples\Tutorial directory.

You can use the Sweep step to sweep multiple parameters simultaneously by adding additional parameters on the Configuration tab of the Sweep Step Setup dialog box. Sweeping two or more parameters in unison is a parallel sweep. For example, if you want to vary the amplitude of a stimulus signal, you can run a parallel sweep. You can use a parallel sweep to maximize the precision of the acquisition by varying the input range of a digitizer or MIO device as you vary the signal level. As the signal level increases, you can increase the input range of the measurement device to ensure you use the entire resolution for the measurement.

**Running Multi-Dimensional Sweeps**

Use multi-dimensional, or nested, sweeps to iterate through one range while you vary another range. For example, if you want to sweep through frequencies of a stimulus signal at different amplitudes, run a nested sweep. You can set the amplitude to level 1 and sweep through frequencies, then set the amplitude to level 2 and sweep through frequencies, and so on. You can build a nested sweep by right-clicking a Sweep step in a project and selecting Add Dimension from the shortcut menu to add another sweep loop.

Complete the following steps to run a sample nested sweep project.

1. Select File→Open, navigate to the SignalExpress\Examples\Tutorial directory, and double-click Nested Sweep.wbp.

2. Click the Run button, shown at left, to run the project.
   Each iteration of the inner sweep loop sweeps the frequency of the stimulus signal. The outer sweep loop varies the low and high cutoff frequencies of the Filter step. Each iteration appears in real time on the...
upper graph, then appears on the lower graph to display all the sweeps at each cutoff frequency setting, as shown in Figure 5-4.

3. Click the **Stop** button, shown at left, to stop the project.

**Figure 5-4.** Nested Sweep.wbp
Extending SignalExpress Projects with LabVIEW

You can use SignalExpress to define automated measurements without programming applications by using built-in steps for acquiring, generating, or analyzing signals. You can extend the functionality of SignalExpress projects by using LabVIEW in two ways:

- Build a user-defined step, or VI, in LabVIEW and import this VI into SignalExpress to expand the number of steps available in SignalExpress.
- Convert a SignalExpress project to a LabVIEW block diagram to continue development in LabVIEW.

You must have LabVIEW 7.1 or later to complete the exercises in this chapter.

Importing LabVIEW VIs into SignalExpress as Steps

Use the User-Defined step in SignalExpress to call custom LabVIEW VIs. You can call a LabVIEW VI from SignalExpress to do the following:

- Control GPIB instruments
- Control National Instruments hardware that SignalExpress does not support
- Read or write data to more file formats
- Display operator instructions in a pop-up dialog box
- Define a measurement algorithm

Complete the following steps to import a VI from LabVIEW with the User-Defined step.

1. Select File→Open, navigate to the SignalExpress\Examples\Tutorial directory, and double-click User Step.wbp.
   This project uses the Create Signal step to generate a signal.
2. Click the Add Step button and select User-Defined Step.
3. Click the browse button on the **Step Setup** dialog box and select Limiter.vi in the SignalExpress\Examples\Tutorial directory. The Limiter VI accepts a time-domain waveform as an input, clips the signal above and below values that you specify in the **Step Setup** dialog box, and returns the clipped waveform as an output signal.

When you import a LabVIEW VI, SignalExpress maps the inputs of the VI as parameters and the outputs of the VI as output signals in SignalExpress.

You can define whether the inputs for VIs become input signals or parameters. An input signal appears in the Project View as an input to a step, which means you can pass signals as inputs to a VI. A parameter is a value you can configure on the **Step Setup** dialog box of a step. You also can sweep parameters dynamically using the Sweep step. In this project, the VI has an input signal **Time waveform in** and scalar parameters **Upper limit** and **Lower limit**.

4. Select **Time waveform in** in the **Parameters** list and click the **Make Input** button to specify **Time waveform in** as an input signal.

5. Select **Clipped waveform out** in the **Outputs** list and select **Time Waveform, Real** from the **Strict Type of Output Data** pull-down menu to specify **Clipped waveform out** as a time-domain waveform.

The **Step Setup** dialog box should appear as shown in Figure 6-1.
6. Click the **Close** button, shown at left, to close the **Step Setup** dialog box.

7. Click the **Run** button, shown at left, to run the project.

8. Drag the **Clipped waveform out** output signal from the Limiter.vi step to the Data View.

9. Double-click the Limiter.vi step to display the **Step Setup** dialog box.

10. Click the **Open VI Front Panel** button to display the VI.

11. Enter new values in the **Upper limit** and **Lower limit** fields. For example, enter 100 in the **Upper limit** field.

12. Click the **Apply** button to apply the changes.

13. Click the **Close** button to close the VI, and click the **Close** button to close the **Step Setup** dialog box.

   The **Clipped waveform out** signal changes on the Data View to reflect the changes you made.
Refer to the *NI Express Workbench Help* for more information about using LabVIEW VIs in SignalExpress and developing VIs that work well in SignalExpress.

**Converting SignalExpress Projects to LabVIEW Block Diagrams**

SignalExpress adds a dialog box to LabVIEW that can convert SignalExpress projects.

Complete the following steps to convert a SignalExpress project to a LabVIEW block diagram.

1. Launch LabVIEW.
2. Select **Tools»Express Workbench»Convert Express Workbench Project** to display the **Convert Express Workbench Project** dialog box.
3. Click the browse button next to the **Project to convert** field and select the **My First Project.wbp** project in the **SignalExpress\Examples\Tutorial\Solutions** directory.
4. Click the browse button next to the **Destination VI** field to specify the filename and location for the new LabVIEW VI.

   You can convert a SignalExpress project into a LabVIEW block diagram that runs continuously, similar to the **Run** button operation in SignalExpress, or a LabVIEW block diagram that runs once, similar to the **Run Once** button operation in SignalExpress.

5. Select the **Loop Mode** option, as shown in Figure 6-2, and click the **Convert** button to start the conversion.
The resulting LabVIEW block diagram reflects the execution of the project in SignalExpress. The LabVIEW block diagram consists of LabVIEW Express VIs wired together. Each Express VI correlates to a step in the SignalExpress project. You can double-click an Express VI to display the same Step Setup dialog box as in SignalExpress. You also can right-click an Express VI and select Open Front Panel from the shortcut menu to convert the Express VI into a low-level LabVIEW block diagram to see how the LabVIEW block diagram executes.
Where to Go from Here

Refer to the following resources for more information about SignalExpress.

**SignalExpress Sample Projects**

SignalExpress provides a variety of sample projects that demonstrate more capabilities of SignalExpress. These projects are located in the SignalExpress\Examples directory. Review these examples to learn more about the features of SignalExpress or to start with a project that closely resembles your needs.

**Using Hardware with SignalExpress**

This manual does not describe how to control hardware from SignalExpress because SignalExpress supports a variety of National Instruments hardware for acquiring and generating signals. You can generate or acquire analog signals in SignalExpress using National Instruments MIO devices, high-speed digitizers, or arbitrary waveform generator and function generator devices. You also can synchronize multiple devices in a system by sharing clocks and trigger signals between devices. Refer to the *NI Express Workbench Help* for more information about using hardware with SignalExpress by selecting **Help»Express Workbench Help**.

**Web Resources**

Refer to the National Instruments Web site at [ni.com/signalexpress](http://ni.com/signalexpress) for resources such as example projects, technical documents, and LabVIEW VIs written for use in SignalExpress.
Technical Support and Professional Services

Visit the following sections of the National Instruments Web site at ni.com for technical support and professional services:

- **Support**—Online technical support resources at ni.com/support include the following:
  - **Self-Help Resources**—For immediate answers and solutions, visit the award-winning National Instruments Web site for software drivers and updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting wizards, thousands of example programs, tutorials, application notes, instrument drivers, and so on.
  - **Free Technical Support**—All registered users receive free Basic Service, which includes access to hundreds of Application Engineers worldwide in the NI Developer Exchange at ni.com/exchange. National Instruments Application Engineers make sure every question receives an answer.

- **Training and Certification**—Visit ni.com/training for self-paced training, eLearning virtual classrooms, interactive CDs, and Certification program information. You also can register for instructor-led, hands-on courses at locations around the world.

- **System Integration**—If you have time constraints, limited in-house technical resources, or other project challenges, National Instruments Alliance Partner members can help. To learn more, call your local NI office or visit ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact your local office or NI corporate headquarters. Phone numbers for our worldwide offices are listed at the front of this manual. You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.